Jump to content


Photo

Ubiquitous 2

ubiquitous2

  • Please log in to reply
162 replies to this topic

#81 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 20 August 2015 - 09:11 AM

Hi,

Viewers counter should be green to get message sending work. Yellow color means that you logged in anonymously.

Please check if Twitch ask you for a captcha on login web page. If it is the case you need to wait some time (make take a hours) and enter right credentials carefuly ;)

 

I didn't test OBS on Win10 but you can try to use Browser source instead of my plugin. 



#82 tck13

tck13

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 20 August 2015 - 18:51 PM

I have watch your code, but can not find the right location where I can change the way that the chat updates on the web version (any where in ubiquitous.js).

Can they tell it me? Other way I have to try and error - it looks like I have to change multiple things. But witch...

Tck13



#83 Jiminimonka

Jiminimonka

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 20 August 2015 - 18:58 PM

Hi,

Viewers counter should be green to get message sending work. Yellow color means that you logged in anonymously.

Please check if Twitch ask you for a captcha on login web page. If it is the case you need to wait some time (make take a hours) and enter right credentials carefuly ;)

 

I didn't test OBS on Win10 but you can try to use Browser source instead of my plugin. 

Turns out the problem with twitch was that I was not streaming. Once I turned on the stream it worked fine. Thanks.

 

Browser source? Like a window capture, or actually a URL to put in CLR Browser?



#84 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 21 August 2015 - 05:47 AM

Well actually it shouldn't be live to work but I'm glad that it work :)

 

You can put URL into the CLR Browser. Check Settings->Services->Web server there examples of URLs are given. 

It also possible to read a chat on mobile device via that Web UI



#85 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 21 August 2015 - 05:53 AM

I have watch your code, but can not find the right location where I can change the way that the chat updates on the web version (any where in ubiquitous.js).

Can they tell it me? Other way I have to try and error - it looks like I have to change multiple things. But witch...

Tck13

Hi,

you can control some appearance parameters via URL (check settings->services->web for examples). 

 

I would recommend to copy content of the Documents\Ubiquitous2\Web to some folder like Documents\Ubiquitous2\Web\My. So it won't be overwritten when update will be released.

Then edit Documents\Ubiquitous2\Web\My\ubiquitous.js and open chat URL by adding folder name you just created, e.g.: http://localhost:8080/my/



#86 tck13

tck13

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 August 2015 - 14:58 PM

That have I already understand - but where in the ubiquitous.js stand where the newest message is (top or bottom). Because it is standard newest message at top but I would like it at the bottom.

tck13



#87 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 21 August 2015 - 15:21 PM

Hm, did you try to open it with "bottom" parameter added to url ? e.g: http://localhost:8080?bottom

I've added few url parameters a week ago. You can find description in the Web server settings



#88 Ash

Ash

    Member

  • Members
  • PipPip
  • 12 posts

Posted 22 August 2015 - 10:09 AM

<removed>



#89 mrpixeltech

mrpixeltech

    Member

  • Members
  • PipPip
  • 18 posts

Posted 27 August 2015 - 23:04 PM

I'm assuming the support for YouTube works with YouTube Gaming (gaming.youtube.com) but wanted to double check.  Also, I've been seeing a lot of comments of severe lag between message origination and display - in my testing, up to a minute from twitch for me to see it on my end (not within obs but the client).



#90 Isegrim

Isegrim

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 29 August 2015 - 21:06 PM

I'm assuming the support for YouTube works with YouTube Gaming (gaming.youtube.com) but wanted to double check.  Also, I've been seeing a lot of comments of severe lag between message origination and display - in my testing, up to a minute from twitch for me to see it on my end (not within obs but the client).

YouTube chat does work partially. Sometimes comments aren't displayed at all, sometimes only a few will appear. 

Twitch messages are being displayed with a one second delay for me but i'm not able to login and post with my username.



#91 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 31 August 2015 - 11:54 AM

Thank you for report. I will test Youtube.

There is delay in the code to prevent fast scroll. I could make it optional though.



#92 alejandroplayz

alejandroplayz

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 01 October 2015 - 21:18 PM

Hello!

I've got 2 problems/question:

 

1. Still can't login on twitch -> post messages :( Tried to wait for 24h but still get message about my "credentionals".

Maybe you should make button to send kaptcha?(

 

2. How can I post message in YT chat?

TY

Your program still AWESOME!



#93 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 02 October 2015 - 08:33 AM

Hi,

 

Unforunatelly its not so easy to impelement Google's captcha in the desktop app. Same with google authentication. 

Thats why you experiencing these problems. 

 

I will try to solve it in some way. Maybe via their OAuth authentication...



#94 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 02 October 2015 - 11:47 AM

Please check current update. I've added OAuth login button to the Twitch. It should help.

You don't need to specifiy password if you use that button.



#95 Roostersnake

Roostersnake

    Newbie

  • Members
  • Pip
  • 5 posts
  • LocationIllinois

Posted 03 November 2015 - 22:14 PM

I am having trouble getting my streamup chat to work. I know I'm using the right email and password. It doesn't matter how many times I restart streamup in ubiquitous2 or ubiquitous2 itself it will not work. Not even read only.

 

Thank you for the program,

                            Roostersnake



#96 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 04 November 2015 - 12:40 PM

Hi,

They changed connection point on the website. In the latest update it is fixed.


  • Roostersnake likes this

#97 Atirion

Atirion

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 04 November 2015 - 14:27 PM

I checked for your github, did you remove it? :P

 

And dunno if you want this here, but it seems to be a problem when you get a few messages. Then it starts spasming out. It jumps to the top of the chat, then scrolls straight back down multiple times. Dunno if other people have this problem, but it's at least something i found very annoying :P

 

And, any way to support your work? :) 

 

-Atirion



#98 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 05 November 2015 - 09:32 AM

Hi,

 

I'm using my code in another project so I had to make my repository private. 

Do you use slide in/out option ? 

 

I don't have any donation accounts yet but I'll consider it. Thank you ;)



#99 Atirion

Atirion

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 05 November 2015 - 13:43 PM

Hi,

 

I'm using my code in another project so I had to make my repository private. 

Do you use slide in/out option ? 

 

I don't have any donation accounts yet but I'll consider it. Thank you ;)

I am not using the slide in/out option. I have tried it, but the problem has been there a while before that. 

I think it might just be the "auto scroll" that wants to be at the bottom, but the chat every time it gets a new message wants to be at the top. so it sort of puts it at the top, auto scroll pulls down and repeating it a few times before sticking to the bottom. 



#100 xedoc

xedoc

    Developer

  • Administrators
  • 1,104 posts
  • LocationKiev, Ukraine

Posted 05 November 2015 - 18:13 PM

Will check it






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users